Toyota Celica Forum banner

1 - 16 of 16 Posts

·
Registered
Joined
·
8,914 Posts
Discussion Starter #1
<font color='#8D38C9'>Okay people... remember my post a few months ago that I wrote about my sister telling me about my engine light and sh!t?  Well, yesterday was sunday so the only thing I was able to do was check the oil.  It's still gold and at the right level.  So I went to the place that did the intake and had them check the hoses and stuff and that's okay too.  I wanted to check with them about that first because I don't want to go to toyota right away and find out the intake and exhaust voided the warranty.
So the guy that checked the stuff out told me to call ahead and ask. I call up the dealership and the guy I talked to was SO unhelpful and all on my case.  I asked him if I could have a list of what would void my warranty and he says something will and something won't, what kind of things did you mean? So i said simple things like an intake and exhaust... and he says well it depends, some will and some wont.  It depends what it does to the engine.  And I said they were pretty basic and just helped it breathe easier.  So he says well some of them can cause problems and turn the engine light on and may void warranty.  So I said, well my engine light IS on, that's my problem, but I'm not having problems with the car it runs fine.  And he goes and says well there IS a problem if the light is on and the only way they can find out what it is is to run this $75  engine test.  And of course if that stuff WILL void the warranty then as soon as I go in and they see it they'll mark it void so I don't want to go unless I'm %100.  So I said that I would think about it and call if I was going to come in.  The people that work there are jerks!

One of my dad's clients recently franchised a toyota dealership and he was telling my dad we should have gotten the car through him and he would have cut us a deal.  So I'm thinking I may go to him first and he may turn a blind eye to the warranty stuff and just tell me whether it will be voided if I take it to the other place.  I may actually get all my stuff done there if he'll give me a deal but I have to wait til Wednesday to get in touch with him. *sigh*
ALSO:  My engine is knocking! Much louder than before, you can hear it with the hood closed and it mostly on the left side on the engine.
AND: That sheet of plastic under the car that protects the engone from stones and sh!t is ripping off!  I don't know how she managed to do that but it's scraping along the road and is damn annoying... plus I'm worried something will go flying into the engine and mess it up.  But I can't get that taken care of either cus then they'll notice the engone light and see the stuff under the hood...
DAMN! I hate all this stuff that keeps happening everytime I leave my car here!

Oh and I went and asked about my footpedal bolt ons that were on backorder when I left.  SO I get there and NO ONE that I know works there anymore!  They've all quit or gone to the other store.  So I tell them what happened and they can't find the damn pedal covers.  I have already paid for them!  They have to call someone who used to work there and let me know whether they're just hidden in the stock room or if they need to reorder them.  *sigh*

So these are all my celi problems.  Any advice or insight or support or anything would be greatly appreciated.  :down:</font>
 

·
Registered
Joined
·
1,313 Posts
<font color='#990000'>I hope your warranty doesnt void..what a waste of 75$
Also, putting pedals on is very easy..You'll be happy when you get em
</font>
 

·
Registered
Joined
·
563 Posts
<font color='#000000'>im not sure what the law is there but id imagine it would vary from state to state as it does here.

however.. here the addition of aftermarket parts to a car does not void the warranty except on those parts modified or changed or any component conncted to the modified conponent.. however if the modified component's failure or as a result of its operation casues an original component to fail then the original component that has failed as a result of your aftermarket product is not covered under warranty.

bascailly if you have an aftermaket oil filter and it bursts and you loose oil you engine seizes then it isnt warranty simply becasue the engine seizure is as a direct reault of the failute of the aftermakret product.</font>
 

·
Registered
Joined
·
8,914 Posts
Discussion Starter #4
<font color='#8D38C9'>Frosty: Thanks hun.  Yeah the pedals are just these red bolt on covers with holes in them so they won't change my racing pedals, just spiff em up a bit.  I may not have to spend the $75, if the guy that my dad knows can't help me out then one of my friends dad has that machine that they use to run that engine test, so she said she could get the unit from him and we could run the test ourselves for free!  But I'll know more tomorrow, I'll call that guy up that my dad knows and if he says he can't help me then I'll have my friend help me and then go to the dealership for the knocking and and the plastic under the car. *sigh*  I can't wait for tomorrow!  Thaen I'll know more of what's going on.

Toof:  Yeah I heard about that before, I think it works the same way here... but that's why I'm not sure whether I want to go straight to the dealer to find out what's wrong.  As soon as they see the intake and exhaust and find something wrong that may be connected to it they'll void my warranty.  So I'm waiting for tomorrow to go to this guy my dad knows and then maybe he'll help me out and at least tell me what's wrong without voiding the warranty.  

I'll update you guys tomorrow when I know more. :down:</font>
 

·
Registered
Joined
·
2,733 Posts
<font color='#000F22'>im sorry to hear what you are going throught, if the car runs fine try resetting the computer, it might have threw a code when it didnt need to, but once it throws a code it holds it well most cars do atleast. either dissconnect the battery for aporx. 90 sec, or take out all the main power fuses. I would dissconnect the battery its easier then trying to find the right fuses ect...
one of my buddies needed warrenty work done before, he had me take off the cai and put the stock one back in for it. do you still have the stock assembly? I always have my customers hold on to them for this reason..</font>
 

·
Registered
Joined
·
319 Posts
<font color='#810541'>my friends rsx has warranty and has put a lot of parts on it, he put headers, cai, pulleys, and they will let him chip the car too</font>
 

·
Registered
Joined
·
319 Posts
<font color='#810541'>he cant put on a turbo or a supercharger though</font>
 

·
Registered
Joined
·
8,914 Posts
Discussion Starter #9
<font color='#8D38C9'>Okay people, here's what's happened:
This morning my dad called the guy he knows and told him I was having car problems.  Mr. Basil was really cool about it, he just told me to come on down right away and ask for Ron or Joe and tell them I'm a friend of his and they'd take care of me
 So I change and go right over and find the dudes I'm supposed to find.  I explain all that sh!t to them and tell them that I'm not happy with my dealer and stuff.  They were very nice and sypathetic, a MUCH better change!  
So they come out to the car and looked at the engine light first, and checked the gas cap... apparently when you close the cap and turn the car on it pressurizes the tank and if you don't turn the cap til it clicks it can leak air and the sensors think there's a leak in the tank.  But it wasn't that.
So then they popped the hood to listen to the "knocking" I mentioned and  to see if there was anything that might look out of place.  They said it wasn't an engine knock, and sounded more like the valve train.  They said they wanted to first run the engine test and see what codes they got.
While they ran the test I talked to the owner and he was a REALLY nice guy.  He checked to make sure the service guys were taking care of me properly and told me not to worry about the warranty and we even talked about racing and I guess one of his guys used to be a TRD manager and he has a few other guys that are really good with performance so they might hook me up !
 I am so excited about that!  So then I sat around for a bit to wait til they were done and when they came back to let me know what they found out he came back out to see what was going on.  He was very involved, and I think it was very sweet of him.
So the verdict is, it's my valves.  They got 3 misfire codes,  one for valve number 1 , one for valve number 4 and one is a spontaneous valve, so it could be any of them going off at any time.  They think that that is what is also causing that engine noise.  So they said that was all covered under warranty so it was free and had nothing to do with the intake or exhaust.  They would pay for a rental car for me as a loaner and have the car ready for me by friday since they may have to shin (?) the valves and get new shins. (anyone know what this means in english??)
As for the plastic under the car they have to order a new one which will be $80, no price to install... and I don't mind spending that since I don't have to spend $72 on a stupid diagnostic test that these guys ran for free.  It will also be in on Friday so they'll do the whole thing in one shebang.  So hopefully my baby will be fixed soon and be back in tip top shape

He also introduced me to Matt, his "celica guy"  who knows all the celi sh!t and Dan, the electronic whiz, who I guess knows all the chip upgrades and timing tricks and things... I AM SO EXCITED!


JHull: Explain to me how to reset the computer, I can just disconnect the battery?  That would be cool... so if it was a serious problem it would stay on and if it was a tripped fuse it'll go out?  Awesome, I'll have to remember that for later, though I guess this time it really was something important.


TCS: Yup


Hawk: I guess it just depends from place to place... These guys seem like they'll let me do stuff to the car and won't mess me up.  The other guys are jerks and just want to screw me over.  I guess it's cuz most of their customers are middle aged or senior citzens
 Oh these guys were even telling me about turbos and nos and all kinds of sh!t, they were SO cool about it all!  :thumbsup:</font>
 

·
Registered
Joined
·
8,914 Posts
Discussion Starter #10
<font color='#8D38C9'>It turns out I need a new belt and tensioner too.  I stopped by to pick up something from my car and they told me the engine light went out and isn't coming back on.  So they're just trying to get the engine to stop making that noise and fixing the belt and getting that new skid guard or whatever it's called under the car...

I'm getting my car back tomorrow, yay!!!!
</font>
 

·
Registered
Joined
·
563 Posts
<font color='#000000'>good to hear youll be back going again... resetting the computer prob isnt the best thing to do there anyway  since it isnt throwing codes resetting it will still leave it throwing codes... and as you can see the computer has actually picked up a rather rasty problem with your engine. so ignorning it isnt wise
</font>
 

·
Registered
Joined
·
8,914 Posts
Discussion Starter #12
<font color='#8D38C9'>Okay people, here's what's going on.
I got my car back on Friday and this is what my statement says:
1- customer states engine light on, please check and advise.  Upon diagnose technician scanned vehicle for codes, present codes PO300, PO301, PO304, misfire codes, technician inspected coil packs, spark plugs, inspected valve clearance, states no problems noted at this time.  Technician roadtested vehicle, unable to recreate misfire codes at this time.  Returned vehicle to customer.
(the reset the computer, the light went out and didn't come back on, even when the drove it  about 12 miles so it might have been a one time thing.  They said to come back if it happens again
)

2- Customer states a valve type noise coming from left side of motor, please check and advise.  Upon inspection of customer concern technician verified customer concern, upon further inspection technician verified noise coming from belt tensioner, technician followed as per T.S.B. EG014-01, replaced serpentine belt and belt tensioner.  Re-checked for noise, no noise noted at this time.
(That noise pretty much went away but I still think it's making much more noise when idling than it should... maybe I'll go back and have them check it again, but I'm glad it's not my valves!!!)

As for my splash shield, the had to order it and I should have it sometime this week, though they managed to repin the part that's hanging down and said they could also just hold the new one til I need an oil change and they can put it on then too.


Oh and my damn red pdals that I've been waiting 5 months for?? I'm still waiting!  They're STILL on (national) back order and hopefully will be in in a few weeks... *sigh*


But other than that all good news
 :thumbsup:</font>
 

·
Registered
Joined
·
8,914 Posts
Discussion Starter #14
<font color='#8D38C9'>ARRRRRRRRRRRRRRRRGHHHHHHHHHHHHHHHHHH!!!! IT'S COME BACK ON!!!! NOOOOOOOOOOOOooooooooooooooooooo!!! I'm going in tomorrow morning again, I hope it's not the valves again
 If it is valve misfire codes again I may have then open up the engine block to check for a bent valve or anything more serious...  It was also idling a little rough the other day but it stopped so maybe it was just the cold damp weather that day.  I havn't noticed any power lag either though... *sigh* I wasn't even driving hard the day the light went off, I was driving a bit hard a few days before and wouldn't have been surprised if it went off that day but I was driving normally for a few days when the light went off so... I'll let you know what happens...
</font>
 

·
Registered
Joined
·
8,914 Posts
Discussion Starter #15
<font color='#8D38C9'>Okay, I took her in this afternoon and they were pretty busy.  I told them the engine light had come back on and they said they were a little hectic at the moment so they couldn't really look at it.  I said I could see (there were people running everywhere and keys and cars all over the place) and asked if they just could pull the codes cuz all I wanted to know was whether they were going to be valve misfire codes again.
So they were nice enough to just hook her up and pull the codes and sure enough, valve misfires.  So I'm going in Wednesday morning to drop her off for them to look at everything and find out what's the deal.  They don't suspect a bent valve or anything serious like that since it took 2 weeks for the light to come back on.
I guess we'll know more Wednesday or Thursday  :eek:o:</font>
 

·
Registered
Joined
·
8,914 Posts
Discussion Starter #16
<font color='#8D38C9'>Okay I dropped her off on Wednesday and they looked at her all day.  They reset the computer again and the light went out.  They checked all my valves and everything they suspected and there's nothing wrong.  So they are at a loss as to say what's going on.  They said next week to come in and they're going to call Toyota and open up a case on the car and see if the techs there can figure out what's going on.  So for now it's off and I have no problems but it's damn annoying.  I mean, the next time it goes off it could be serious and I'll be like oh yeah it's nothing and then my engine goes and blows up or I get stranded on the thruway or something... not good...  :(   So I guess we'll see more later.  I don't think anyones reading this stuff... maybe I should start a new topic??</font>
 
1 - 16 of 16 Posts
Top