Toyota Celica Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I have a 90 celica st 1.6 I’ve checked vacuum hoses cleaned throttle body burped coolant I’m pulling my hair out any help would be appreciated. It isles high warms up then goes from 1.7k to about 2.1 k in a rythmic tone any suggestions or help would be greatly appreciated
 

·
Registered
Joined
·
173 Posts
I'm sure by now you've done some searching for the problem on the net.
Here's one link that might help.
1992 Celica 2.2 idle problem | Toyota Nation Forum
If you search "Toyota celica idle surge" you'll get more suggestions.
One had the problem with a Honda, (on YouTube) where the intake manifold gasket was broken/cracked and that solved the problem.
Let us know what you find.
 

·
Registered
Joined
·
258 Posts
Pull the vacuum hoses one at a time and plug them at the intake manifold (cap on the manifold nipple). If still high, pull the intake air pipe to gain access to the throttle body. Plug the various openings on the outside of the butterfly. (Passages are for minimum idle, cold start, and emissions)

If no change, then computer might be registering rich and adding air to compensate resulting in higher idle.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #5
Update I got the intake manifold gasket in today going to do it before I go to work. My neighbor is actually a Toyota mechanic and has been helping me he says vacuum leak thank you sefiro I will try that once I change the gasket if issue is still present I still have the timing belt to do as well (just to make sure). Will keep you all updated on my journey hopefully this forum will help others with similar problems once again thank you all for taking time out of your days to try and help out.
 

·
Registered
Joined
·
2 Posts
I have a 90 celica st 1.6 I’ve checked vacuum hoses cleaned throttle body burped coolant I’m pulling my hair out any help would be appreciated. It isles high warms up then goes from 1.7k to about 2.1 k in a rythmic tone any suggestions or help would be greatly appreciated
 

·
Registered
Joined
·
3 Posts
Update I got the intake manifold gasket in today going to do it before I go to work. My neighbor is actually a Toyota mechanic and has been helping me he says vacuum leak thank you sefiro I will try that once I change the gasket if issue is still present I still have the timing belt to do as well (just to make sure). Will keep you all updated on my journey hopefully this forum will help others with similar problems once again thank you all for taking time out of your days to try and help out.
I've got a 91 4A-FE, Im having the same issue high, rough idle at start (2.2k I live in a cold climate so I have no idea if this is the average speed for 20-40 degree weather). After about 15 seconds my idle will bounce by about 500 rpm until a load is put on it. I've not been able to figure this out, nor has my mechanic so any update is appreciated.
 

·
Registered
Joined
·
258 Posts
If it surges, drops and surges again, it's in idle hunt due to a vacuum leak. Have plug intake manifold puts one at a time until it stops.
 

·
Registered
Joined
·
3 Posts
If it surges, drops and surges again, it's in idle hunt due to a vacuum leak. Have plug intake manifold puts one at a time until it stops.
Thanks for the input! Tragically this was my first stop and my mechanics as well and it was to no avail. I even took apart the throttle body, and AAV for a deep cleaning thinking it was that. I also tested the TPS and it tested fine according to the service manual.
 
1 - 10 of 10 Posts
Top