Toyota Celica Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hi there,

As stated in the title, I'm having an issue with a slight lag in throttle. I've adjusted the throttle cable slightly as there was quite a lot of slack/play but I'm still getting the the lag with what sounds like a small release of air (which sounds like its coming from the filter area)

Please help!

Many thanks
 

·
Registered
Joined
·
1 Posts
+1 on this issue except I have A lot of lag and pretty loud air noise out of air filter. Previous owner put an aftermarket intake on the car. Maybe we have the same issue. Wondering if possible air leak now.
 

·
Registered
Joined
·
208 Posts
If you had some slop In the cable, then the cable may be fraying. Disconnect it and see if it moves freely.

Lag in acceleration could be tune/misfire, low fuel pressure or a partially clogged exhaust
 

·
Registered
Joined
·
44 Posts
Have you checked the tube from the air box/filter to the intake manifold? After a few years they will crack or split between the accordion ridges and air will be sucked in the split. That would bypass the air sensor in the filter area and screw up your air/fuel mix. I'm not to schooled on the ECU but I think it needs the air flow input sensor info for the fuel feed. In turn could cause the lag and the sucking sound. IMHO. Worth a look see.
I've got my tube wrapped in Flex tape and black electrical tape :D
 

·
Registered
Joined
·
3 Posts
Discussion Starter #7
That’s definitely all worth investigating, thank you!..Mine does have an aftermarket exhaust too, that could be worth looking at also👍🏼
 
1 - 7 of 7 Posts
Top