Toyota Celica Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
I'd like to share my experience on the dreaded P0420 Code, Catalyst System Efficiency Below Threshold (Bank 1). I'm by no means an expert so feel free to comment or critique me in any way you feel necessary. My hopes are to help others troubleshoot this code.

In plain English the code means your catalytic converter isn't efficient as it should be. Your car's ECU knows this by comparing the oxygen level before the catalytic converter to the level tof oxygen after the catalytic converter using the two oxygen sensors mounted in the exhaust pipe.

Let's review a second. In a catalytic converter, the catalyst (in the form of platinum and palladium) is coated onto a ceramic honeycomb or ceramic beads that are housed in a muffler-like package attached to the exhaust pipe. The catalyst helps to convert carbon monoxide into carbon dioxide. It converts the hydrocarbons into carbon dioxide and water. It also converts the nitrogen oxides back into nitrogen and oxygen.

So basically the post cat O2 sensor is looking for more oxygen in the exhaust compared to the pre cat O2 sensor to check efficiency of the Cat.

Now keep in mind if you have other codes along with the P0420 there maybe something causing the inefficiency of the Cat. For example, if you're running too rich or too lean this may destroy the Cat, contaminate it or burn it up, so make sure you have fixed all other codes before troubleshooting the P0420.

My car is a 2002 Celica GT with 150k miles on it. Some people were telling me to just change the rear O2 sensor first and if that didn't work, try the front O2 sensor. I guess one sensor could go bad but in my case I didn't have any specific O2 sensor codes and I didn't want to throw down at minimum $120 for two O2 sensors and then have to go for a new Cat anyway. The next step was to figure out if my sensors were functioning normal. In my research on the net the normal voltage output for the sensors should be between .1 and .9 volts. I also found that normal behavior is for the front sensor to fluctuate up and down (maybe due to fuel trim?) and the back sensor to hold more steady at around .7 volts which I assume would be a good indication of more oxygen in the exhaust. You can use any OBD2 scanner with live data to see the voltage readout of the sensors. I, myself, purchased an ELM327 wifi OBD2 scan tool from eBay for $22 and the ios app, Dash Command, for another $10 for my iPhone. I was easily able to see what my O2 sensors were doing on a graph for a mere 32 bucks. The outputs were normal voltages but what I had was the rear O2 sensor mimicking the front O2 sensor's waveform. At this point I was inclined to say the Catalytic Converter wasn't doing its job and the sensors were just fine. I went ahead and purchased a direct fit Catalytic Converter, installed it and immediately had normal results. A steady .7 volts at idle for the rear O2 sensor. Of course as I drove around the rear voltage would change but not following the front sensor anymore. I reset the CEL, took it for a drive, got all my readiness indications on the OBD2 readout and passed inspection with no problem.

I hope this helps anyone who might be troubleshooting the P0420 and let me know if it does but there's one last dilemma I face. In theory, a catalyst does not go bad by itself. Something else will usually cause failure of a Cat. There's the oil consumption problem associated with the 1zz engine so that could be the cause in my case but my old Cat didn't look at all contaminated nor did it have burn through. I also just bought the car a few thousand miles ago so I don't know its full mechanical history. I'll have to keep an eye on things but hopefully I'm good for another 150k.
 

·
Registered
Joined
·
476 Posts
Usually P0420 is related to one of your pre cats. I had this code on my Nissan. O2 sensors have their own "P" codes.
 

·
Registered
Joined
·
1 Posts
0420 Issues can anyone help

Hello All I really hope someone here can help.

I have a 2003 Toyota Celica GT with 180,000 miles
a year ago my engine light came on thats the beginning of this aggravation. I had the code read P0420 code Catalyst System Efficiency Bank 1 ok fine i had my 02 sensors replaced and after that replacement i than had the same error code except this time it was the catalytic converter needed replacement. 2 weeks ago i went to have it replaced and the mechanic said their is absolutely nothing wrong with my C converter and showed it to me it was squeaky clean. Okay, so than I looked into simple things i changed my gas cap, and just yesterday replaced the PCV Valve and Hose and the engine light came on again this morning reading the same P0420 code. Im beyond frustrated not sure if it can be the manifold air intake.

Can anyone help?

Thanks
 

·
Registered
Joined
·
3 Posts
The PO420 code in Celicas is typically real and is due to fouling of the catalytic converter due to oil burning.

I have had this code for approximately 8 years and it has not effected ability to drive.

To pass inspection, reset Codes using OBD2 scanner and put through a drive cycle, can find a good PDF of what a drive cycle looks like for Celica, the Evap monitor will not restore, which is okay as long as all others are restored.

Depending on how bad it is, you may need to space the second O2 sensor out using a spark plug non you let or spacers available on Amazon.
 
1 - 7 of 7 Posts
Top