Toyota Celica Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hi, i just bought myself a 2000 celica GT. After a couple days of having the car the check engine light comes on. At low rpm the car is a bit jumpy, once it gets into 4000 or so it is a lot smoother. the weird thing is that i flashed the ECU while connecting up a new head unit. Once i reconnected the battery and started driving, the car was a lot better, the idle speed wasn't as low and the car was all in all running decently. After about 5kms the problems started again. Now when i press the gas at idled the rpm drops to maybe 50 almost dying before quickly shooting up, even if i have already release the gas. I checked the error codes, got a p0172, engine running rich. Checked the air filter, filthy, switched it, cleaned the MAF with MAF cleaner because that was also filthy. Cleaned the intake manifold. Cleaned the throttle body with throttle body cleaner. Was thinking maybe it was sticking, which could explain the delayed response. To no avail. The only difference is that after i flashed the ECU after cleaning all this out, it takes longer for the check engine light to return. Which is some sort of progress atleast, but still not solved. The longer i drive around with the check engine light on the worse it gets. once i flash the ECU all the problems disappear for a while. Could it be the o2 sensors? running out of ideas here and would love to hear some thoughts :) Thank you :)
 
1 - 2 of 2 Posts
Top