Toyota Celica Forum banner

1 - 20 of 62 Posts

·
Registered
Joined
·
1,656 Posts
Discussion Starter #1
<font color='#FF0000'>okay, my check engine light came on the other day and everyone is confused why. Here are some contributing possibilities...

1. on 2 seperate occasions I let two different boys run my car a little and both misshifted (second wasn't that bad)

2. got new spark plugs put in after the first misshift because of Rosie's "cough" (missfiring). btw, I got good spark plugs, not crappy ones...

3. for a while, we disconnected my muffler and I was riding just with a straight pipe... (hope that makes sense). At first I liked it b/c it was louder so I did that for a few weeks, then I hated it so it was reconnected, then I liked it, then I hated it and so on... So for about 3 weeks I've had it connected and I don't plan to mess with it anymore b/c it.. uhh.. it sounds like ass. heh. :blush:

4. I dunno if this means much... but I don't always put in Premium like it says on my car... About half of the time or more I put in Midgrade (never Regular).

I think thats about it... oh, and it has 66,333 (or so) miles on it. Also, after the first misshift and Rosie was missfiring and I replaced the plugs, she' has been running and handling perfectly. No problems driving at all. So anyways, my light was on and then I took my car to a friend and he relearned my car's computer, I drove it for 8 miles and all that. When he was relearning it, the first test showed 1 missfire. The second test showed 3 missfires. The third test didn't show any missfires. So afterwards, my light was off. I guess I'll just see how she does... if the light comes back on I'll just go from there.. What do you guys think?  
o:</font>
 

·
Registered
Joined
·
563 Posts
<font color='#000000'>as far as the fuel you are running the 2zzge engine youve got requires a min of 96RON fuel.. not sure what your diff grades of fuel are over there but ours are regualr 89RON, premium 96RON,, and we can also get 98RON pretty easy as well..

running too low a RON fuel can casue all sorts of nightmares.</font>
 

·
Registered
Joined
·
1,656 Posts
Discussion Starter #3
<font color='#FF0000'>thanks, toof. Premium from now on. Our premium is 93 I believe and our Regular is 89. But we can also get 100 octane at some gas stations.</font>
 

·
Registered
Joined
·
563 Posts
<font color='#000000'>if your in doubt ask at the servo. gut iirc the 2zzge needs 96RON so without it expect problems. thats the issue you have ith high compression engines.</font>
 

·
Registered
Joined
·
8,914 Posts
<font color='#8D38C9'>Actually Luv, I think in the states regular is 89, super is 93 and premium (aka super plus) is 96... with the exception of a few places that also sell 100...  Check the next time you fill up your tank
 I think that's how they're labeled at the Mobile by my house.  I ALWAYS use 96 with the exception of a few times I've gotten 100, but it's DAMN expensive, but it really helps, I've really noticed the difference when I fill up an empty tank, 100 is all my dad will use on his motorcycle, but then again the tank only holds like 3 gallons!
</font>
 

·
Registered
Joined
·
1,656 Posts
Discussion Starter #6
<font color='#FF0000'>well my light came back on today...  :down:  Just before I went to the gas station to fill her up with Premium. My X boyfriend,the one who badly misshifted is saying that it might be a bent valve. I dunno... it could be lots of things. This sucks.  :(</font>
 

·
Registered
Joined
·
224 Posts
<font color='#000000'>...  Well if it is a valvue it will be tapping.  Like a little fingernail tapping on teh inside of your valvue cover.  Dont worry about the fuel issue.  Thats not enough to totaly f u c k you engine.  Two missshifts uless like from 5th to 2nd will not hurt "rosie"... ???  that bad.  Thats why u got a rev limiter, for those who cannot drive or suckers.  so.  How does your car start cold, is the light always on, is there tapping, or any other noises.  Give me something to go on.  ANything.  Hopefully it is nothing serious.  Just a dumb wire or something but let me know.</font>
 

·
Registered
Joined
·
1,656 Posts
Discussion Starter #8
<font color='#FF0000'>yeah, it's tapping. Nothing rough, just a slight little tap like you described. I can feel it in the steering wheel if I pay close attentiona dn I can hear it if I turn off the radio. When I start it in the morning, she doesn't do anything peculiar and she always runs fine. i always give her time to warm up...
Today I heard it could be the valve ring... would that make sense? It would cause the engine light to come on and the missfires I hear. It would cause me to lose like 1/2 a horsepower. So if it's just the ring it's no biggie right? I can just get it fixed in my own time...?  ???  Yes, the light is always on. It went off for like... 4 days after I relearned my cars computer but today when I started it in the middle of the day, it came on right as I started it.  There are no other noises. Now. Does that help at all? and yes, my car's name is Rosie.


btw, I candy coated my corners Toyota Red.
Looks good... and I painted did my calipers the toyota red over that ford red. it looks much better... matches my intake. I'm going for that candy apple red on all my mods.  
</font>
 

·
Registered
Joined
·
224 Posts
<font color='#000000'>ok luv, sounds like a valuve.  Uh not really a problem unless tapping gets loader, meaning more valvues are out of wack.  YOur timming might be a degree or so off, hence the missfires and spark problems but ultimatly it a valvue.  I wouldnt let it go on for too long, just bad for Rosie.  Its like a headache.  Not always bad but it would be nice to get rid of.  If you need more spesific help or somethin re post or email [email protected]</font>
 

·
Registered
Joined
·
1,656 Posts
Discussion Starter #10
<font color='#FF0000'>thanks soooo much!
You're awesome, you've been a great help. But how do I go about getting it fixed? Just take it to pep boys or something and tell them to fix my valve? I don't know what number it is... btw, I mean what is the cheapest way for me to get it fixed.   :blush:</font>
 

·
Registered
Joined
·
224 Posts
<font color='#000000'>Uh s h i t.  I would have to say DIY get a manual and go at it.  But i dnno.  Pep Boys doesn't really have my stamp of aproval.  They can do brakes and tune ups but its a valvue adjustment which is not difficult but a pain to get started and finished.  It depends if it is just an ajustment take it to a shop it should be relatively inexpensive.  Dont take any ####, like if they are like, you need all new valvues we cant just fix one.  Or you ought to get new retainers and seals and no.  It a valvue adjustment.  To bad I cant look at it cause i could tell you what to do.  Cause there is a chance there could be more wrong with it.  Like seals and stuff.  

I know, take it to two or three shops just have them listen to it.  They should all say the same thing and whoever you feel more comfordable with take it to them.  Cost depends rates in Arizona are like $55 + an hour.  Its about 4 hours or so.  
  so there u have it.  good luck hope Rosie gets better
</font>
 

·
Registered
Joined
·
1,656 Posts
Discussion Starter #12
<font color='#FF0000'>nah, I can'tbe going all up in my engine and doing stuff like that. *L* I wish I could. My boyfriend... who is now my X used to do my engine work but so much for that. Now I'm on my own..
I dunno, I know a lot of car people and mechanics... I'll figure something out. *sighs* This is what really sucks about being a chick. *L* I'm afraid everyone is going to try to screw me over. hmm...   :down:  well I'll get it it within the next couple of days hopefully and let you know how it goes... Thanks so much for your help.   :grin:</font>
 

·
Registered
Joined
·
8,914 Posts
<font color='#8D38C9'>Isn't CelicaXIV great Luv?? It's nice to have someone besides JHull here who knows about fixing sh!t up...
 Maybe he can figure out why MY light is on since the dealer can't seem to find the problem and has to open up a case on her
 ehhh it's all under warranty so it's not a biggie, it's just annoying... and it'll have to wait til spring when I go back to see her...
Hope Rosie gets better soon :grin:
</font>
 

·
Registered
Joined
·
224 Posts
<font color='#000000'>Glad to see I can be of some use.  So Meryem what seems to be the problem.  Just like I asked luv, is there tapping, how is the cold start, anything smell funny.  Lemme know and I will do my best to help.</font>
 

·
Registered
Joined
·
1,656 Posts
Discussion Starter #17
<font color='#FF0000'>okay here's what happened. The other day I went to the toyota dealership (not where I got mine) and spoke with the toyota techs. They listened to my car and basically just told me to come in and get it a dyagnostic test on it.. they also got me to by new TOYOTA spark plugs instead of my other ones that I just bought (Boshc or however it's spelled) b/c they said that Toyota doesn't get along with any other spark plug than toyota ones. So there's 50 bucks I spent on 4 plugs.. then I told him that I used to put Midgrade gas in... he said I need to get a Fuel Injector Service.... 60 bucks. so.  :eek:o:  he never really told me there was one particular thing wrong with it... he said there are a lot of possibilities. I'm probably just gonna do what he said tho... I guess. I told him about my intake too... which can make the engine light come on, but not cuase my car's ticking and missfiring. Well, I'll let you guys know how it goes I guess....

Oh yeah, on a better note, I got a red TRD sticker put on today on my sunroof. It's like 10 inches by 25inches... looks pretty good. I like it. It's the Papyrus font, slanted and bolded. It looks bad as hell.  :grin:  :thumbsup:</font>
 

·
Registered
Joined
·
8,914 Posts
<font color='#8D38C9'>CelicaXIV:  Well I'm not with my car at the moment and won't be for a few months but I'll you what happened as short as I can cuz it's a long story... there's a whole thread about it somewhere here, maybe on the 3-4th page.  I was away again.  My lil sister told me the light came on and there was a rattle.  I told her put it in the garage and don't touch it.  When I came back I called my dealer, decided they were a$$holes and found out my dad knows another dealer personally.  Went to them, was very happy.  They didn't void my warranty or anything cuz of the exhaust or intake, etc.  They pulled misfire codes and when they reset the computer the light went out.  They drove for ~10 miles and it stayed out.  They figured a one-time thing.  I mentioned a rattle and they found my belt tensioner to be the problem, replaced it and the serpentine belt.  2-3 weeks later the light came back on.  I went again and the pulled misfire codes again.  I left the car for them to do a more thorough investigation, incl the valves but they didn't find anything.  They said generally when theres a problem like this that after the 3rd time the light comes on they call toyota, open a case on the car and talk directly to toyota staff and techs and troubleshoot with them.  They said I didn't need to wait for the 3rd time and to leave it but I had to leave again so I'm waiting for my dad to drop her off.  They asked about the intake but my light didn't come on for at least a month after I had the intake, and like Luv said, I don't think that would cause misfire codes.  There's no smell except when you have gunned it hard and you get that funny burnt oil smell but that's normal.  Cold start is okay, I've noticed having to crank it a bit more but I think that's the intake.  The "rattle"/tap I heard before has diminished with the new BT, but I think it's still making more noise than it should.  I really want them to get this fixed before my warranty runs out!  What do you think?

Luv: QUOTE
*falls in love with her new hero*[/B]
LMAO!  Hey I saw him first!!! lol j/k...
  You have to get pics of your sticker up!  And I hope they get Rosie sorted out soon, poor thing
</font>
 

·
Registered
Joined
·
224 Posts
<font color='#000000'>hmmmmm.

Luv:  Ok well the whole spark plug thing, meh.  A good set of NGKs or Denso platinums would have done the trick but $50 not horrable if it keeps the techs off ur ass.  Keep a straight mind.  DOnt let the fact that Rosie is sick get u down and that the prolem is unclear.  It gets to the point where ur like just get the s h i t fixed and get my car back ASAP.  thats when u look at the receipt and it is like $1000 some bucks.  I know how it ism I am trying to get my vlavues adjusted but dont have time with school being away from home.  Plus I am on my 3rd engine and its only been a monht and the vavues are tapping.  The spirits of dead hondas are taking over our poor celis i swear.  
As for the injector treatment, that is not a bad idea.  ALl they do is take all 4 inectors and use sound waves to clean and knock all the grit out of them.  Its a good deal.  I wish i could be of more help but take it to toyo and do ur best to get it fixed.  But it is usually the little thing that cause the big things and u are still in the little things stage so, as always dont take their bs.  Keep your eye on the prize and u can email me if u got an urrgent question [email protected]  that goes for everyone.

Uh Meyrem:  Well that is no good.  At least toyo is opening a case.  THe tensioner,  my friends broke last weekend and we though he blew his engine.  Good call by toyo.  Well I dont know they have the car and its in good hands,  WE hope.  and i hope it gets out soon.  Damn gremlins.  It is under warranty so get as much done while it is under as u can.  See if any of the new stuff is warranties.  Like i told luv any urgent stuff eamil.  

All the best girls</font>
 

·
Registered
Joined
·
8,914 Posts
<font color='#8D38C9'>Thanks Ian, but you have no ideas huh?  Oh well, I'll def keep you guys posted whenever I find something out... I wonder when my warranty runs out, I think I got the extended one... I'll have to double check  :eek:o:</font>
 
1 - 20 of 62 Posts
Top