Toyota Celica Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
I have a 2000 GTS. I cannot get fuel to the rail.
Replaced
ECM
Fuel pump
crank sensor
all coil packs
start switch on back of ignition switch
I have flushed the fuel line , tank to rail
The only way it will run is if I force fuel into the carb.
My mechanic hooked up his scanner.
Was able to turn on and off the fuel pump. I only hear the fuel pump when I turn off the ignition.
He tested each relay. Both were clicking.

Anyone have and suggestions?
 

·
Registered
Joined
·
329 Posts
Just a thought you might want to check. The fuel pump is a DC motor that can run either forward or backwards depending on how it is wired. Is it possible that when you replaced the pump you somehow mixed up the + - wires? The pump would run like normal, you would hear it but it would not be pushing fuel but sucking it out of your system.
It's happened before to others.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
Just a thought you might want to check. The fuel pump is a DC motor that can run either forward or backwards depending on how it is wired. Is it possible that when you replaced the pump you somehow mixed up the + - wires? The pump would run like normal, you would hear it but it would not be pushing fuel but sucking it out of your system.
It's happened before to others.
I thought the same thing. There are two connectors so the is no chance of reversing the current. The other new fuel pump I changed out I noticed the same issue. When I bench tested I reversed the wires and it pumped. So where is the problem if its plug n play connections?
 

·
Registered
Joined
·
329 Posts
I'd try reversing anyway, nothing to lose. Wouldn't be the first time manufacturers screwed things up.
Other than that I'm out of suggestions unless I think of something during the day :unsure:
 
1 - 4 of 4 Posts
Top