Toyota Celica Forum banner
1 - 20 of 21 Posts

·
Registered
Joined
·
6,814 Posts
Discussion Starter · #1 ·
So it is Friday and Spring Break has started. No one is here and I have to sit around until Sunday before I fly home. I am really super bored so I took some pictures of my car since I realized I don't really have any with the new turn signals. The car isn't really clean, I just decided to do this at random. My camera sucks and I don't know how to use it so the quality isn't the best either.















I took some lame videos too. I'll post them once I get my damn YouTube account to work.
 

·
Registered
Joined
·
6,814 Posts
Discussion Starter · #2 ·
Since YouTube is being gay I decided to use Photobucket.

Walkaround while idling:


Exhaust: (That blue stuff isn't burning oil; it is performance smoke) Exhaust setup is a 2.5" testpipe followed by a 2.5" Pacesetter catback. I hate how it sounds; I am going to be putting the catalytic converter back on in May.


Here is me trying to drive, shift gears, and hold a camera all at the same time without killing myself or others:


I think my brother got a decent camcorder recently so I hope to get some good flyby videos after the catalytic converter is back on.
 

·
Registered
Joined
·
6,814 Posts
Discussion Starter · #4 ·
It always seems to happen that way, doesn't it?
 

·
Registered
Joined
·
844 Posts
yea really nice!!! btw did you paint your rims? id imamgine they were stock color and these look nice gunmetal, i am planning on painting mine similar to those because mine are ghetto lol
 

·
Registered
Joined
·
6,814 Posts
Discussion Starter · #9 ·

·
Registered
Joined
·
6,814 Posts
Discussion Starter · #11 ·
Drove the car up to Bartlesville yesterday and it started overheating. Piece of crap.
 

·
Registered
Joined
·
6,814 Posts
Discussion Starter · #13 ·
Could be a number of things. I know the alt/fan belt is loose, so that may be a problem. Thermostat may be bad. Fan clutch could be going out. There could be a coolant leak somewhere. Could be the beggining of a blown head gasket.

I drove it about 45 minutes on the highway and then beat on it a while around town. I parked it and started it and when I started it back up it started to overheat a little. It would overheat in traffic and when pulling hills going ~40mph or so, but once on the highway it was fine.

I need to find a friend that isn't half retarded to help me tighten up the alt belt to see if that fixes it before I start spending money on stuff.

Shitbucket.
 

·
Registered
Joined
·
3,358 Posts
Well on the subject of broken cars... My Blazers front passenger ball-joint just let go at lunch
 

·
Registered
Joined
·
6,814 Posts
Discussion Starter · #15 ·
 

·
Registered
Joined
·
6,814 Posts
Discussion Starter · #17 ·
I think I've narrowed down the overheating problem to a bad fan clutch. I'm going to be replacing that, the water pump, and several other things as soon as I get my relocation money for my new job.
 

·
Registered
Joined
·
1,199 Posts
sweet supra doug....not a fan of the 80's cars..but urs is definately hott....

pllllllleaaaaaaaaaseeee dont start with the cars breaking down thing agian...this just happend to me last month and i cant handle more
 

·
Registered
Joined
·
402 Posts
there are only 3 affordable cars from the 80's I would own. the first being a supra, the second being an mr2, the 3rd being a camaro.
 

·
Registered
Joined
·
331 Posts
what was the problem? i had the same problem and it was my radiator. there was a big crack next to the cap. 125 dollars and shipped to my house in 3 hours. so basically i was carless for 3 hours. =D gotta love radiators.com
 
1 - 20 of 21 Posts
Top