Toyota Celica Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hey everyone I'm working on my friends daughters 2000 celica, she was in traffic about 2 weeks ago when the car just died. Long story short had to tow it home and have been busting our brains since then. The issue is no fuel pumping to fuel rail and the EFI NO. 1, 7.5 amp fuse blows the second you turn on the ignition. If I pull the EFI relay fuse is ok, we have tried swapping the relay, unplugging everything we can think of to try to isolate the issue even the fuel pump itself and still pops the fuse instantly and the car just turns over and will never crank. Can anyone please help give some direction where to look..... this has been going on for a while with zero luck.
 

·
Registered
Joined
·
96 Posts
Logically there must be a short circuit between the EFI 1 relay to the fuel injectors. Both the EFI 1 relay and the fuse are in the engine bay fuse box That wire runs from the fuse box to the injectors..

Check the wires from the injectors back to the fuse box for any exposed wire, cracked/broken insulation, short to ground or other wires. May be the short is right at the injectors' terminals.
.
To be more exact, look up the schematic for which wires, which colors and what connector positions EFI 1 comes out of the fuse box to the fuel injectors. Focus on those wires and you will find the problems.

Hey everyone I'm working on my friends daughters 2000 celica, she was in traffic about 2 weeks ago when the car just died. Long story short had to tow it home and have been busting our brains since then. The issue is no fuel pumping to fuel rail and the EFI NO. 1, 7.5 amp fuse blows the second you turn on the ignition. If I pull the EFI relay fuse is ok, we have tried swapping the relay, unplugging everything we can think of to try to isolate the issue even the fuel pump itself and still pops the fuse instantly and the car just turns over and will never crank. Can anyone please help give some direction where to look..... this has been going on for a while with zero luck.
 
1 - 3 of 3 Posts
Top