Toyota Celica Forum banner

21 - 23 of 23 Posts

·
Registered
Joined
·
65 Posts
Discussion Starter #21
And another..... The code 12 was from the dist. When I installed the new rotor and cap I musta not got the cap entirely on straight. I pulled it off and made sure everything fit snug and easy. No more code 12.
I'm beginning to long for the days in the '50s when engines just required fuel and spark to blow up.
 

·
Registered
Joined
·
65 Posts
Discussion Starter #22
OK I did get a chance to run it again today. Back to square one ... sorta.
I have some pics here. The code 12 was cleared, it was the "dizzy" thank you.
Ran for 6 minutes before it died. I spent lots of time looking for that cold start injector on the intake manifold, no luck. Some pictures here and if you can point it out sure would appreciate.
I did jump that time/thermo and no difference.
There is a picture of the exhaust. Keep in mind that the outside air temp was around 45deg F and the steam dissipated, no smoke but a definite smell, water dripping from the tail pipe.
What really frustrates me is that it will not throw a code for the problem. After I cleared the 12 and after it quit I checked for a code and got the steady blink of normal. Go figure. A question for an opinion. The key/start ignition switch doesn't always make a good contact or maybe the starter circuit. Battery tests good but it is old, When I turn the key it the solenoid clicks but no turnover. Sometimes two or three times and then it turns over. Would a bad key switch cause some of these issues? The PO said that they had to put a separate push button under the hood because it wouldn't start after the engine warmed up.
31567
31568
31569
31570
31571
31572
31573
31574
 

·
Registered
Joined
·
65 Posts
Discussion Starter #23
Here's another little sweetheart I found this afternoon. Checking out everything that leads into the intake manifold.
The mounting screws were set with factory red paint spots so assuming the thing was never serviced. Needless to say they were a ...... to take out. Had to soak them with PB Blaster and then smack a few blows with an old Philips stub
31575
31576
and hammer. Connections are clean. the brass insert was froze tight, no movement at all. Let carb cleaner soak in the throttle body hole for a few hours and finally got the brass to twist about 1/8 to 1/4 turn CCW. Just something else to add to the list.
Any knowledge on how much it's supposed to turn, I don't want to break anything. The magnet works fine.
 
21 - 23 of 23 Posts
Top