Help with starting! - Toyota Celica Forum
User Tag List

 
LinkBack Thread Tools
post #1 of 2 (permalink) Old 08-21-2019, 06:19 PM Thread Starter
Member
 
Join Date: Aug 2019
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Default Help with starting!

Hey! So I own a 89 Celica GT and I'm having some issues narrowing down an issue, some times when I attempt to turn the car completely on (crank it) I have no response, but have feel access to electricity inside the car, I repeatedly crank the key anywhere between 4-10 times and it'll come right on, I just had my alternator replaced, and my battery was just checked today!
Demolishn is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 08-29-2019, 11:36 PM
Member
 
Imahoggfarmer's Avatar
 
Join Date: Jan 2013
Location: Austin Texas
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Default

I have a 93 and it was doing same thing. Mine was the fuse under the hood. Not sure what it’s called but it’s a huge fuse but posts on it are very thin. It was loose in socket. So I put some stripped wire folded over both legs so it would be tighter and it’s been working fine
Imahoggfarmer is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome