Help with starting! - Toyota Celica Forum
User Tag List

 
LinkBack Thread Tools
post #1 of 4 (permalink) Old 08-21-2019, 07:19 PM Thread Starter
Member
 
Join Date: Aug 2019
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Default Help with starting!

Hey! So I own a 89 Celica GT and I'm having some issues narrowing down an issue, some times when I attempt to turn the car completely on (crank it) I have no response, but have feel access to electricity inside the car, I repeatedly crank the key anywhere between 4-10 times and it'll come right on, I just had my alternator replaced, and my battery was just checked today!
Demolishn is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 08-30-2019, 12:36 AM
Member
 
Imahoggfarmer's Avatar
 
Join Date: Jan 2013
Location: Austin Texas
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Default

I have a 93 and it was doing same thing. Mine was the fuse under the hood. Not sure what it’s called but it’s a huge fuse but posts on it are very thin. It was loose in socket. So I put some stripped wire folded over both legs so it would be tighter and it’s been working fine
Imahoggfarmer is offline  
post #3 of 4 (permalink) Old 09-19-2019, 07:58 AM
Member
 
Join Date: May 2016
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Default

Same issue, alt. and three starters, new battery. Seems there is a short in the rear pass. brake light that burnt the fuse box under dash.
stevetess1 is offline  
 
post #4 of 4 (permalink) Old 10-27-2019, 11:47 PM
Member
 
Dake's Avatar
 
Join Date: Oct 2018
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Default

I had a similar problem in my '89 and it turned out to be a leaking o-ring where the distributor plugs into the block. There was engine oil inside the distributor!
Dake is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome