Cold engine stalling on my 2005 - Toyota Celica Forum
User Tag List

 
LinkBack Thread Tools
post #1 of 1 (permalink) Old 11-20-2019, 11:55 PM Thread Starter
Member
 
Join Date: Nov 2019
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Default Cold engine stalling on my 2005

Hello all,

I have a 2005 8th gen, it has 110k on it. I have had this issue with the engine stalling when ever it's cold weather here in florida(40F), it does not happen during the summer. The car will start fine but imediately it will stumble and the rpm will reach to 300 or so then it will die. It stays running if I give it gas and it drives fine. When ever it dies I get a misfire code but I dont think it has anything to do with spark. I have replaced coil packs, fuel pump and filter, and cleaned the throttle body and Idle Control Valve.

Anyone have an idea of what it might be?

Also, if I fill the car with gas while it's running it will die. I wonder if the car has a sensitive EVAP system or some issue..

Any help is welcome!

Thanks
Jacob Moses is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome