How do I replace O2 sensor? - Toyota Celica Forum
User Tag List

Reply
 
LinkBack Thread Tools
#1 (permalink) Old 10-21-2005, 10:06 PM
Guru
 
Join Date: May 2005
Posts: 122
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
(Thread Starter)
Default

How do I replace O2 sensor? Is this easy to do? Do I have to worry about computer code or error code when replacing.


The reason why I want to replace the sensor is because I consumed too much gas. My full tank is about 200 -215 miles. Local drive.

Had replaced wires (ngk), plugs (denso platinum), oil change (synthetic), flush radiator last summer. Before this, my full tank is about 180-190 miles. I have little improvement.
90GT-S is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 10-21-2005, 10:45 PM
Guru
 
Join Date: Sep 2005
Posts: 184
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Default

I recently did this to pass e-check, there good for 100,000 miles with a 4 wire O2 sensor which i thinka ll 5th gen celicas are, 2 wire sensors are 50,000 miles. The down pipe connected to the manifold is where it is located. Look at a picture of a oxygen sensor then look around where the pipe curves from the engine down to the exhaust pipe. Mine had some crappy stock metal tub around it so it took me a good 3 hours to bend that off and put the oxygen sensor in. But i would say without any problems 30 45 miniutes.
zztrent is offline  
#3 (permalink) Old 10-22-2005, 12:47 PM
Old Timer
 
Join Date: Oct 2003
Location: Norman, OK
Posts: 2,406
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Default

it just screws in and out

VTECKiller is offline  
#4 (permalink) Old 10-22-2005, 11:23 PM
Guru
 
Join Date: Sep 2005
Posts: 184
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Default

also lots of rust usualy get PB blaster
zztrent is offline  
#5 (permalink) Old 11-03-2005, 02:57 PM
Guru
 
Join Date: May 2005
Posts: 122
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
(Thread Starter)
Default

I got the OE denso oxygen sensor yesterday. I need help how to replace it. Do I need to take out the cover plate or I can just squeeze in the tool throught that small opening. I was trying to unscrew the plate but can't. It's all rusty.
90GT-S is offline  
#6 (permalink) Old 11-03-2005, 03:50 PM
Old Timer
 
Join Date: Oct 2003
Location: Norman, OK
Posts: 2,406
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Default

youll probably have to take the heat shield off to get enough space to move the wrench. Unless you have an extremely deep socket that will fit over it, just use a wrench and pry the **** out of it.

And DO NOT touch the new sensor's sensor nose

VTECKiller is offline  
#7 (permalink) Old 11-06-2005, 04:36 PM
Guru
 
Join Date: May 2005
Posts: 122
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
(Thread Starter)
Default

I just replaced the ocxygen sensor today. I wasn't able to remove the cover plate so I used the long socket to get into the sensor. it wasn't rusty so it's so easy to remove. Just have a hard time unclipping the plastic connector.

The tip/tube looks whitish. What is it?

Any more sensor I need to change like under the car along the exhaust pipe? is this only for california?

What improvement will I see besides the gas mileage? Will that reduce that surging noise that I hear when I drive. There are time I have to put up the vol. of the radio. it's loud inside the car not outside. Will this replacement help with my emission. Eversince NY emission reduce the NOx from 4.00 to 2.00 I failed. I always get value around 3.4. Also hole in my exhaust will that alter my emission results? My next inspection is still next May 2006. I have to do the brake first.
90GT-S is offline  
#8 (permalink) Old 11-06-2005, 04:53 PM
Guru
 
Join Date: Sep 2005
Posts: 192
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Default

surging noise?? do you only hear it when you are on the gas?

1992 Black Celica, 451xxx KM and still goin
clay is offline  
#9 (permalink) Old 11-06-2005, 05:25 PM
Guru
 
Join Date: May 2005
Posts: 122
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
(Thread Starter)
Default

Yes I notice it when I drive/on the gas.

I don't know how to explain it but sounds like humming sound/high idle but it's not idling high when I check rpm. Sounds like when engine is still cold (not winter cold). I hear it inside the car not outside. I hear it when I drive. I think there are times I hear it when car is not moving. I don't know if thats due to hole in pipe (will have this fix after the brake). Outside the car is not noisy my sister said she only hears the noise from pipe hole. My brother couldn't pinpoint the problem. He told me to do the regular maintenance first. He changed plug wires (NGK), denso platinum, toyota distributor cap and rotor, synthetic oil 5w with restore. I still hear the noise. I haven't driven the car after I changed the oxygen sensor I just drove it back and forth the street for a couple of minutes.

Do you know what's that noise?
90GT-S is offline  
#10 (permalink) Old 11-06-2005, 05:36 PM
Guru
 
only16Gt's Avatar
 
Join Date: Sep 2004
Location: California
Posts: 413
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Default

sorry to but in but where and how much did you get the sensor for. also the wires i have been looking for set but have been unsecsessfull


Eagle alloy rims,limo tint,OBX high performance exhaust,Clarion Pro audio deck,200 watt amp,pioneer 4" up front,6" kicker's in back, 10" pioneer subwoofer. clear corner and bumper lights. weapon r dragon intake system. New block. Interior neon. three peice spoiler, sirius sattelite radio, cobra 9700 radar detector, undercar neon, blue glow gauges
My Ride
only16Gt is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome