'94 engine stalls out randomly while driving - Toyota Celica Forum
User Tag List

 
LinkBack Thread Tools
#1 (permalink) Old 12-02-2010, 11:48 PM
Member
 
Join Date: Dec 2010
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
(Thread Starter)
Default

I have a '94 celica GT. I have replaced fuel pump, fuel filter, spark plugs & wires, distributor cap and rotor and the car still stalls randomly while driving. I wait a few minutes and the car will restart. Something overheats and causes engine to cut out. When the car restarts it may run for a few miles and then it will stall out again. Anyone know what is going on?
schroeder27 is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 04-04-2011, 10:20 PM
Obsessed
 
Lafraga00's Avatar
 
Join Date: Apr 2011
Location: Venice, Florida
Posts: 88
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Garage
Default

your distributor is a fault..replace it if u still have the celcia
Lafraga00 is offline  
#3 (permalink) Old 09-02-2011, 03:17 AM
Member
 
Join Date: Oct 2010
Posts: 14
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Default

The same exact thing just happenned to me today. did u ever fix your car? if so please let me know waht it was so i can have an idea of where to start. thanx
rider1522 is offline  
#4 (permalink) Old 09-22-2011, 10:26 PM
Member
 
Join Date: Apr 2011
Location: Greencastle, IN
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Default

I am having the same problem with my 93 Celica convertible. I started with replacing the fuel pump. That worked for a couple weeks. My mechanic said the code indicated it was the throttle positioning sensor. He replaced it and all was good for a few days and then it started all over again. He thinks it is a bad TPS. I still don't know what's going on. I do know it has a hesitation at low speed unless I give it a lot of gas. I LOVE this car but I am tired of getting stranded. And I have spent WAY too much money on it to give up on it. Someone has to know what the fix is? If anyone figures it out please email at dlshow@ccrtc.com. I am beginning to have to eat my words about how dependable Toyotas are
dlshow is offline  
#5 (permalink) Old 10-01-2011, 10:05 PM
Member
 
Join Date: May 2011
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Default

I had the same issue with my 93 celica convertible - turned out to be a bad distributor shorted out the ECU. I had both replaced with used/remanufactured parts and ran good for 300+ miles but now something else is wrong...car has no pickup and runs rough
93CelicaNJ is offline  
#6 (permalink) Old 10-16-2011, 02:19 PM
Member
 
Join Date: Apr 2011
Location: Greencastle, IN
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Default

Have you ever figured out what the problem was. I am having the same problem with my 93 GT. My mechanic has replaced the coil, distributor and all associated with it, Throttle positioning sensor, MAP sensor, fuel pump. ABout the oly thing remaining is the ECU. It only happens after driving it for an hour plus. The computer is throwing NO CODES. it will run about 5-10 MPH but give it gas and it cuts out. Any idea!
dlshow is offline  
#7 (permalink) Old 05-04-2012, 12:54 PM
Guru
 
Join Date: Feb 2012
Posts: 127
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Default

mines dies randomly but fires right up. from past experiences id just start with the basics to clear that outta the way, i havnt started taking care of my problem yet but im starting with timing belt, compressions and leak down, plugs wires cap and new distributor then TPS then what else could it be right?
stihlayota is offline  
#8 (permalink) Old 05-04-2012, 02:16 PM
Guru
 
Join Date: Oct 2011
Posts: 128
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Default

does it sound as if you have a cylinder misfiring or feel like your flooding/not getting fuel to the engine and shudder? How about re-starting do you have to wait awhile or does it always start right back up? Check your engine coolant temperature sensor they seem to go bad on the 94's there was a TSB on it awhile back ill find the info for you all.

Currently restoring a 1994 Celica GT to her former glory
evil bender is offline  
#9 (permalink) Old 03-23-2013, 02:47 PM
Member
 
Join Date: Jun 2012
Location: southern PA
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Default

all of u try some sea foam for ur gas tank. mine did the same thing and i replaced alot including throttle positioning sensor alllll of my sensors really ecu and wires and still nothing sea foam was put in it after i sold it and then it ran perfectly fine....let me know how it goes.
hmercier1714 is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome


Search Engine Friendly URLs by vBSEO 3.6.1